Zoopla Enquiries

Incident Report for Callwell

Update

We are continuing to work on a fix for this issue.
Posted Jul 03, 2025 - 13:25 IST

Identified

At the moment, your Zoopla enquiries may not display in the same way that you are used to. We are working on it.
All other functions of Callwell are working normally.
Posted Jul 03, 2025 - 13:24 IST

Investigating

At the moment, your Zoopla enquiries may not display in the same way that you are used to. We are working on it.
All other functions of Callwell are working normally.
Posted Jul 03, 2025 - 13:23 IST
This incident affects: Callwell Frontend Application.