Temporary telecoms issue
Incident Report for Callwell
Resolved
12.01 - 15.03.21 - System status normal
Posted Mar 15, 2021 - 12:02 GMT
Update
We are continuing to investigate this issue.
Posted Mar 15, 2021 - 12:01 GMT
Investigating
10.09 - 15.03.21 - Temporary telecoms issue - Our IVR provider has been alerted and is actively investigating
Posted Mar 15, 2021 - 10:10 GMT