Intermittent call issue
Incident Report for Callwell
Resolved
A solution was implemented at 12.55pm today and we are happy that this issue has been resolved.
Posted Feb 14, 2024 - 16:38 GMT
Update
We are continuing to investigate this issue.
Posted Feb 14, 2024 - 16:36 GMT
Investigating
Some branches have reported that calls are not dialling the customer when they "press 1". We are urgently looking into this issue and apologies for any inconvenience.
Posted Feb 14, 2024 - 12:49 GMT