Callwell - disruption to service
Incident Report for Callwell
Resolved
This incident has now been resolved.
Posted Jan 12, 2022 - 10:59 GMT
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 10:58 GMT
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 10:54 GMT
Investigating
We are currently investigating a disruption to the Callwell service.
Posted Jan 12, 2022 - 10:44 GMT
This incident affected: Callwell Frontend Application.