Callwell - possible disruption to service
Incident Report for Callwell
Postmortem

Our phone call service provider, Twilio, experienced network issues for a short time between 9am and 10am on Wednesday 31st. This caused some phone calls on the system to fail or experience delays reaching the end customer. This was rectified shortly after and no leads were lost during this time.

Posted Jun 01, 2023 - 09:27 IST

Resolved
This incident has been resolved.

Our phone call service provider, Twilio, experienced network issues for a short time between 9am and 10am on Wednesday 31st. This caused some phone calls on the system to fail or experience delays reaching the end customer. This was rectified shortly after and no leads were lost during this time.
Posted May 31, 2023 - 10:28 IST
Investigating
We are currently investigating a possible disruption in service.
Posted May 31, 2023 - 09:52 IST