Reports of duplicated leads sent from a portal

Incident Report for Callwell

Resolved

The portal has confirmed that this issue has been resolved.
Posted Mar 26, 2025 - 09:16 GMT

Investigating

We are aware of a current issue were a portal is forwarding historic duplicated leads to Callwell. This has been reported to the portal and we are awaiting a resolution. Unfortunately we are unable to assist further with this matter.
Posted Mar 25, 2025 - 15:31 GMT