Possible temporary telecoms issue
Incident Report for Callwell
Resolved
No further reports of issues from our telecoms provider.
Posted Jun 13, 2022 - 16:02 IST
Investigating
Temporary telecoms issue - Our IVR provider has alerted us to a possible issue linked to a small region of the UK and is actively investigating.
Posted Jun 13, 2022 - 09:58 IST