Disruption in service

Incident Report for Callwell

Resolved

As this is a third-party issue we are closing this status.
Posted Jun 17, 2026 - 17:15 IST

Identified

We’ve been informed that there is currently a Microsoft Teams platform issue affecting all branches using Teams for telephony. This appears to be the cause of the call failures being reported.
Posted Jun 17, 2026 - 11:46 IST

Investigating

We’re currently investigating an issue affecting outbound and inbound calls. Our team is working on it and we’ll share an update as soon as we have more information.
Posted Jun 17, 2026 - 11:09 IST
This incident affected: Callwell Frontend Application.