Interruption to Callwell services
Incident Report for Callwell
Resolved
This incident has been resolved and Callwell services have resumed.
Posted Aug 02, 2021 - 10:51 IST
Monitoring
Normal Callwell service has been resumed although we are monitoring the system for performance.
Posted Aug 02, 2021 - 10:44 IST
Identified
We apologise for the current disruption, the issue appears to be with our service provider, Amazon Web Services (an industry leader) with whom we are in constant contact. Our team is working extremely hard to get Callwell back for your use. In the meantime, you should receive your leads in your inboxes as this disruption is not affecting emails.

Please rest assured that numerous backups are in operation and no leads will be lost during this time.

We will update this page again at 11:30am BST
Posted Aug 02, 2021 - 10:37 IST
Investigating
We are currently investigating an interruption to the Callwell service and will notify asap with any further information
Posted Aug 02, 2021 - 10:10 IST
This incident affected: AWS amplify-eu-west-2.